You are not connected to a node

I have been using the site to upload my wallet and stake my KSM.
Not had any issues but now for some reason I get the pink banner saying…

“You are not connected to a node. Ensure that your node is running and that the Websocket endpoint is reachable”

I use to get this but it would just flash then it would go to …

“Waiting for your API to be connected.”

Then it would load my KSM wallet , show my available KSM and bonded KSM etc.

Now it is just the pink banner and when info to ‘settings’ it will take me to the page with the ‘general’ & ‘developer’ tabs.

So trying to fix this I will make sure the address network prefix dropdown is on KSM but even after saving and reloading , I get told I am not connected to a node with the pink banner again.

I’ve been using this without issue but today all the sudden I can’t get past this. I’m sure I’m going to find out it’s something basic I’m missing, but maybe someone could tell me how to correct this and why this has suddenly changed.


1 Like

I am experiencing the same. We’re you able to resolve?

1 Like

Nope. I’ve tried everything. On all platforms. All I can come up with is that the network has to be down. I doubt that’s it but I can connect to every other one without issue. Just not KSM.

1 Like

In Settings set "remote node/endpoint to connect to
" to wss:// and click “Save & Reload” button

Thank you so much!!
Where did you get this address from as what I found and added as custom was different to this. If you have a link would be great so I can figure out why I was wrong and learn from my mistake. Maybe I was reading the wrong thing or haven’t read what I need to read. Either way, I thank you for taking the time in replying.

Is there any chance you might also know why I can not see my balance of KSM on the Polkawallet app?

I now , again, thanks to you, see my KSM on the polkadot.js app or address in chrome, but if I upload the KSM address to Polkawallet like in the picture, it won’t show me any KSM. It is as if it only cares about DOT tokens and not KSM tokens. I changed the node to the one above and no difference. I am using a KSM address and not the 5xxxx address. It’s not really that important die to that wallet being super slow at reloading the main page but it would be a bit clearer I think having that user interface. Please see images of the Polkawallet which is showing 0 asset, but if I was using Chrome I would see my staking and my bonding and so assets etc. I have gone through the user guide and nothing changes.


Thank-you Retotrinkler. You came up with that one.

Hey @MrDobalina it looks as though Polkawallet doesn’t support the specific address type for Kusama yet as the address will be different for DOT vs. KSM. Will get the Polkawallet team member in here to confirm the latest.

There have new version (0.1.11) for polkawallet. Last version support KSM, but the kusama somthing has been changed. so need change code. So the new version is support it.

If new version can’t show the balance, he was create the account by web apps with Sr25519. The wallet is Ed25519.

Should this remote node be the same still or should it change with the new version or updates?
Also should I set the same remote node in the polkawallet as the polkdot. Js app?

For some reason I can’t get the option in polkawallet to nominate and change nominations or add etc. I only get the option to bond more and when I click on bond more it doesn’t give me the option to bond more KSM only a bunch of other ones but also DOT. it lands on DOT like that’s what I’m clicking to bond more of.

I’d really appreciate your assistance as you sorted me last time really well. Thanks.

Each time I use polkawallet it says UPDATE FAILED.
It would just be nice if I could use all the things that the screenshots on their website shows. All I get under staking account actions is BOND MORE. but if I go to polkawallet. Js I can do everything I need to.

I’d love to know how long a “era” is though.

Any assistance would be great.